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1 General

The RTStand User Interface idudly -customizable user interface W TestStand.(and
optionally to NI VeriStand)lt merges the user management, reporting and sequence editing
capabilites of NI TestStand and the new, control and visualization power of RTStand.

=
Fle Edt Eecute Debug Configure Tools Help . .
L AL
Valec WS s e w
Exports In Tastin z
powered by o - e ) 18.11.2014 1633
Sequence Flss (1) Home | Sequence Fie
| Monsea
Current Sequence Fie
T:\Sequences\Man.seq
Project Description
EOL MBH ~ WKS Informati
Ulnerstrasse 8
88212 Ravensburg
Tel, 0751 36 660 60
Fax. 0751 36 660 66
Valeo
Valeostrasse 1
86650 Wemdng
Contact:
C. Pfeffecer: +49 9092603204
RunUUTs  SngkPass  Run Sequence
Execuons (0) |
Documentation TOMS Viewer  Database  Configuaton  Runtme Info |
Debug ou: Memory v
% Sow ek User admnatator |Model: ValeoSequertiaiModel_. [No Sieps Selected Number of Sieps: 22

Fig.1. RTStand user interface for a Valeo project

Almost everything is customizable, offering treeuthe unique opportunity to define his own user
interface and extend it with his own code, with very low (or none) programming effort.

_— Customizable

€ _ Flexible

NI LabVIEW
m —_——* NI TestStand
NI VeniStand
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2 Main Structure
Each User Interface installation comes with a file structure as follows:

izl [Documentation]
i71 [Examples]
in | |[Executables]

o]
Il [SourceCode]
o version bet

Fig.2. Folder structure

The Documentation folder includes the necessary documentation for the user.

The Examples folder includes some NI TestStand Sequences allowing the user to see how the
interaction between NI TestStand and RTStand User Interface takes place.

The Executabléolder has the User Interface executable and also the Subpanel LLBs necessary
for the Custom Views (€hapter2.1.7).

The ExecutablaBin folder contains two subfolders: User and Wgsinilar to the NI TestStand
folder structure)

lmd [User]
il [Wks]

Fig.3. Folder struture User/WKS

The User Subfolder will contain all the customized necessary files for the configuration, in a
similar manner as the WKS folder. As long as the User folder has no content, the default WKS
content will be used.

In these folders the most impant file is the Config.ini file. This file defines the most important
settings for the User Interface, such as visible Tabs, Custom ViéWsfger 4 and Logos.

The SourceCode folder can be provided upon corresponding licensing contract with the
purchasing company/person. Please contact WKS Informatik GmbH to see if you are entitled to
the User Interface source code.

The version.txt contains the history of changes/updates made to the User Interface.
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3 Functionality and description

3.1 User InterfaceStructure

The User interface has several areas of functionality, each having its own customization
capabilities, from fixed to fully usedefined.

The structure is presented in the following Screenshot:

B TestStand User Interface

File Edit Execule Debug Configure Tools Help
r ogout
VO W 'K Informatik. Login and current time (adminstrator
[ | owered by Experts In Tasting version 8.4 data 0012018 0914 m

Sequence Files (1 Home | sequence Fie j—— [Tabs with specific display capabilties
pﬂ Main seq

Current Sequence Fle

C:Wwhs_projekteWWKSOperatorinterfaceWExamplesWMan seq

Project Dascrption

-

RunUUTs  SnglePass  Run Sequence

E . o H [;
[Executons (0}
Dacumentation Viewel Database o / Runtime Infa

u s T
,‘V“‘"‘TH'.'- 397 % 32568 | User. administrator Model: SequentialMode... No Steps Selactad Number of Steps: ..
—

Fig.4. User Interface

Below we will present ezn area andts functions.

WKS Informatik GmbH UstIdNr. DE 203907999 Geschéftsfiihrer
Ulmer StraBe 8 88212 Ravensburg HRB 552079 Ronald Kaempf
Tel: ++49 (0)751 / 366 60 60

www.wks-informatik.de Seite6 von32




WKS Informatik GmbH RTStand User Interface

3.1.1 User Logo

File Edit Execute Debug Configure Tools Help/Z|User-definedlngn |

7 - _
e W KS Informatik
. bowered by Experts in Testing

Fig.5. User logo

There are two ways to implemeatuser logo into the interface:

- Recommended:Saving a logo file as ClientLogo.jpg in the ExecutaBl@dUseh folder

A E-I}enll_ogo ipg "-"“i
Fig.6. User logo path

- Savinga logo file in the Executablégin\Usel folder and editing the Config.ini file
correspondingly (be awathat relative paths to the Config.ini are neededThapter 4

| Config.ini - Editor

Datei Bearbeiten Format Ansicht 7

[Logos]
ClientLogo = ClientLogo. jpg

Fig.6. Config.inii User logo

A Important: the size of the Logo must be 60x385 px.

The version displayed is the one defined in the version.txt file.

3.1.2 User name and date

According to the user management functionality defined in the user NI TestStand application, the
logged in user will be displayed, as well as the current time. Térecas logout anytime, as long

as the test is not running. Upon logout, several functions may be disabled, as defined in the user
managemen(s. Chapter 5)

administrator

ogout
18.11.2014 14:17

Fig.7. Login button
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3.1.3 Terminate All

Next to the Login button, the user can find the Terminatéutlion. Its main purpose is to
terminate all running sequences.

Terminate

administrator

20.01.2015 09:22

Fig.8. Terminate button

3.1.4 Stop Testing

Next to the Login button, the user calsofind the Stop Testinghutton. Its main purpose is to
terminate all running sequencascording to a preefined Shutdown routing his has to be

defined in TestStand and must be linked in the Tools menu to the User Interface under the name
AStopTestingo.

This button is deactivated if there is no such linkage in the Tools menu.

administrator ggout
20.01.2015 09:22

Fig.9. Stop Testing button

3.1.5 Shortcuts

The four buttons in the lower left side of the interface represent a shortcut -aefiredid
functionality. This functionality is and must be defined in the Tools menu of NI Test$sand.
Chapter 5)

These buttons are deactivated if theneassuch linkage in the Tools menu.

Documentation TDMS Viewer Database Configuration
UEUUL CPU: Mernary:
. 1,49 % 4,78 GB

Fig.10. Shortcut buttons
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3.1.6 Debug Window

Next to the shortcuts, two displays show the current CPU and system memory usage.

Documentation  TDMS Viewer Database Configuration

Fig.11. Debug data

Upon clicking on the Debug button, the Debug window will be displasleowing detailed CPU
and memory information.

?: Debug ‘2'7|
Update rate: 2000 ms - History Hide FP
CPU: 0,89% Memory: 4,79GB at: 18.11.2014 14:28 &
) CPU: 24,00% Memory: 4,79GB at: 18.11.2014 14:28
CPU Usage:| 3,23 % I CPU: 0,01% Memory: 4,81GB at: 18.11.2014 14:28

Memory Commited: 4,70 GB 4825GE -
i

4,82 GB -
4,815G8-|
4,81GB -
4,305 GB -
4,368~
4,795 GB -

4,79 GB -

Memory Avaliable: 15,8 GB

4,785 GB -}

4,78 GB -, |
366 466

Fig.12. Debug window

The user has the possibility to save the values at different times, thus controlling ist system. This
is useful when the user changes its system and wants to be sure that the pegfstays the
same.

The window can be hidden at any time.
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3.1.7 Sequence / Execution Display

(Sequence Files (1) ]

‘ ‘mj Main.seq

The loaded sequences and corresponding executions (at runtime) are
displayed on the right side.

Using the shortcut menu, the user can start the sequenge/close other
sequencedn a similar manner as in NI TestStand

b Test UUTs F5
b Single Pass STRG+F5

F Run MainSequence

= Open Sequence File.. STRG+0
Close Sequence File STRG+F4

Fig.13. Sequence display

Executions (0)
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3.1.8 Tabs

The RTStand User Interface consists of 7 tabs, each having a specific purpose.

3.1.8.1 Home tab

Upon loading a sequence, therde tab becomes active.

[ Testtond User Interface = | (o]
File Edit Execute Debug Configure Tools Help

T 7 sammsttr
voun S Informatik : :
| powered by Sxperts in Testing erson 94 20.01.2015 09:50 ﬂ

Sequenca Files (1) Home | Sequence Fie

] Mainseq

WKS Informatic

Ulmerstrasse 8
88212 Ravensburg

Tel. 0751 36 660 60
Fax. 0751 36 660 66

Run UUTS Sngle Pass  Run Sequence

| Execusons (0)
- Runtme Info

Dedug cPu: Memory:
- 3,57 % 28968 User. administrator Model: SequentialMode... INo Steps Selacted Number of Steps:

Fig.14. Home tab

The current sequence name is displayed, along with a project description and picture, which are
defined in the loaded sequence. This data is stored in files in the root project and can be changed
by the user amrding to his purposd$or how to configure this, s. Chapters 4 and 5)

The Home tab also has 3 buttons, allowing the sequence start in 3 modi: run uut, single pass and
sequence run, corresponding to the NI TestStand capabilities.

Run UUTs Single Pass Run Segquence

off»

Fig.15. Start seqence buttons
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3.1.8.2 Sequencd-ile tab

If the user has a corresponding NI TestStand license, he has the possibility to edit the sequences

inside the user interface, on the Sequence File tab. Most of the NI TestStand functions are

available for this purpose.

Y Teststand User Interface
File Edit Execute Debug Configure Tools Help

Sequence Files (1 Home | Sequence Fie

] Mainseq

Step

E Sewp (§)
£ Claar All
@Clear Al
,E\salsiams
£ Set onine repon
4 SatColumnsF orOnineReport
@ Columns for Online Report
<End Group>

& Main (17)

‘ % ) <
WK
[ | powered by

Informatik

Exparts in Teating

verson 8.4

Descriplion

Call UserinteiaceMessage in <Current Files
Call UserinteriaceMessage in <Current File>

Locals ColumnsF orOniine Repon{l] « "StepName”, Locals ColumnsForonineRepor]..

Call UserinteaceMessage in <Current Files

admanstrator

20.01.2015 09:52

Setings
Result Recording Disabled
Result Recording: Disabled

Result Recording: Disabled
Result Recording Disabled

Step Types.
EHea04n
=0 Tests

3 Action

B Sequence Call

2 Statement

& Lobel

o For
B Mumenc Limit Test
29 Statement
® Oniine Repont

3 wait
1% Send Status
@ Si3us Message

@ DefauliOveriew
@ DefaultDisplay

assfFail Test
13 Statement

L =0 Local 10 L
Numenc Lima Test, 99 <=x <= 101
Losals O

Call UserntertaceMessage in <Current ile>
Tumelntervali2y
Call UserntertaceMessage in <Current ile>

Call UserntertaceMessage in <Current File>
Call UserinteriaceMessage in <Current File>

Pass/Fail Test

p Name, Locals OnlineRep.

Locals OnlineReport StepName = RunState PreviousStep Name. Locals OnineRep

Result Recording Disabled

Result Recording Disabled
Result Recording Disabled

Result Recording Disabled

Result Recording Disabled
Result Recording: Disabled

Force Pass
Result Recording Disabled

=3 Message Popup
B8 Call Executeble
L ) Propeny Loader
B; FTP Files
4 Additional Results
« 3 Flow Control
+ [ Synchronizotion
Templates
+ O Steps
+ (3 Variables

g&rﬂ:e Report gz”::ﬂs:w:;acehﬁessage in <Current File> Result Recording Dizabled + 0 Sequences
n ' @ Result Recording: Disabled “Drag Tempiate fiere
<End Gioup> B
Variable Value Type - | Sequence Comment
- £ Locals (‘MoinSequence') o] |
+ [ ResultList ) Array of Re | [E] UsedmerfaceMessage
@ MyNumber o Number B SequenceFilsLoad
+ [ OnlineRepart Container
* [ ColumnsForOniineRte... & Array of St
+ [71) DutOverview @ Array of St
| Executions (0 '
Dacur Configurat Runtime Infa
Debug PU: Memory:
- 4,25 % 345 68 User. administrator Model: SequentialMode... No Steps Selactad
Fig.16. Sequence file tab
This tab can be hidden at runtime, as defined in the configuration file.
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3.1.8.3 Overviewtab

Upon starting the sequence, the execution tabs become active. The Overview tab is fully
customizable and displays whatever informationuser needs-or how to build a custom
overview, see Chapter 6.

For example, it can display some DUT information, as seen below:

A TestStand User Interface - Test UUTs - Mainseq [3] [
File Edit Execute Debug Configure Tools Help

o 7 WKS . | admistrator

YOUR l nformatik

[ | powared by Expartain Teating varsion 9.4 20.01.2015 09:54 o)

Sequence Files (1) Overdew | Execution Oning Regort | Custom Views | Report
Execubons (1)
£y TestUUTs-Mainseq[3]
o Paused

Runtims Info
0

Dedug U Memory:
B Geen | 556 | (oo admsia Wodet Seqersaiiods

Fig.17. Example Overview tab

This tab can be hidden at runtime, as defined in the configuration file.

An example from an &gal project looks like this:

Overview | Execution | Online Report | Custom Views | Report ‘

Info DUT 1 -

Partnumber
HW
swW
FR1_Matrix
FR2_Matrix
Test
Start time
LoopCounter A%

i

WKS Informatik GmbH UstIdNr. DE 203907999 Geschéftsfiihrer
Ulmer StraBe 8 88212 Ravensburg HRB 552079 Ronald Kaempf
Tel: ++49 (0)751 / 366 60 60

www.wks-informatik.de Seitel3von 32




WKS Informatik GmbH RTStand User Interface

Overview | Execution | Online Report | Custom Views | Report |

Info DUT 1 ~

Partnumber ‘

A
5

FRL_I Description

FR2_I =
Te

Start

LoopC

Messages

This tab should be used for general information like number of DUTs cilmeent state, current
test state, error display etc. Of course it can be used as well for more specific purposes, if desired.

3.1.8.4 Execution tab

The Execution tab displays the current NI TestStand sequencer. This is helpful when wanting to
observe the sequence flow.

The two buttons on the tab, can Pause and Resume the execution and also Terminate it.

R Teststand User Interface - Test UUTs - Mainseq 3] e
File Edit Execute Debug Configure Tools Help
7 % admnstrator
YOUR Informatik A
'l powered by Experts in Testing verson 06 20.01.2015 09:55 ﬂ
| Sequence Files (1) Overview | Executon | Onine Report | Qustom Views | Report
|[Execuons 1)
TestUUTs -Mamnseq[3) Step Description Settings Stas
Paused & Setup (6)
£ Clear Al Done
@ Clear Al Call UserintedaceMessage in <Current File> Result Recording Disabled Passed
@ ciear Sians Call UserinterfaceMessage in <Current File> Result Recording Disabled Passed
: Setonine report Done.
79SetColumnsForOnineReport Locals ColumnsForOnlineRepor{0] = “StepName. Locals ColumnsForOnlineRepor . Result Recording Disabled Done
@ Columns for Online Repart Call UseriterfaceMessage in <Current File> Result Recording Disabled Passed
<End Group>
= Main (17)
a} For {0} Locals MyNumber = 0. Locals MyNumber < 10. Locals MyNumber += 1 Result Recording Disabled Done_
8 Numeric Limit Test (0}, Numeric Limit Test, 99 <=x <= 101 Emied |
A Statement s = RunState. L \g Disabled Done -
@ Oniine Repot Call UserinterfaceMessage in <Current File> Result Recording Disabled Passed
T wait Timelnterval2) Done
& Send Status Done.
@ Staus Message Call UsernerfaceMessage in <Current File> Result Recording Disabled Passed
@ DefaultOvervew Call UserinterfaceMessage in <Current File> Result Recording Disabled
@ DefaultDisplay Call UserinterfaceMessage in <Current File> Result Recording Disabled Passed
PassfFail Test PassFail Test Force Pass Passed
20 Statement Locals -R [t po Disabled Dane
Oniine Report Call UserinterfaceMessage in <Current File> Result Recording Disabled Passed. .
Wait edn B _Waitng |
¥ End Resull Recording Disabled ~
Variable Valve Type - Call Stack Entry Thread
- £l Locals ('MainSequence’) 2 | W{ManSequence - Main (Main seq) “MainSequence - Main (Main seq) (03]
+ [T ResultList Array of Resultf0. B TestUUTs - Mam (SequentiaiModel Seq)
[ MyNumber 0 Number
+ @ OnlineReport Contsiner
+ [ ColumnsForOnlineReport Array of Strings[0.
‘ il V-
Runtime Info
0
Debug P Memory. -
- 255% 3,07 8 User. Model No lected Number of Steps.
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This tab can be hiddeat runtime, as defined in the configuration file.

3.1.8.5 Online Reporttab

The Online Report tab displays information which was tagged as relevant by the user in his
sequence. This is done using a special custom step type, which is included in the installatio

The information can also be filtered on the tab, by result and by step type, thus allowing the user
to visualize only relevant data.

To see how to send information to the Online Report tab, have a look at Chapter 6.

Fig.19. Online report tab

This tab can be hidden at runtime, as defined in the configuration file.
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